Getting Uncaught Error Assertion Failed Ember Views Require Jquery Between 1

    Table of contents

Getting "Uncaught Error: Assertion Failed: Ember Views require jQuery between 1.7 and 2.1" with app created through ember-cli

Tags: javascript , ember.js , ember-cli Answers: 1 | Viewed 8,998 times



I'm starting with ember. I followed the Getting Started guide at emberjs.com and managed to create a new ember application by running the following commands:


npm install -g ember-cli
ember new sample-app

Everything went successful and I can see the app files generated by ember-cli. Soon after that I did:


ember server

The command line shows:


version: 1.13.13
Livereload server on http://localhost:49153
Serving on http://localhost:4200/
Build successful - 4426ms.
Slowest Trees | Total
----------------------------------------------+---------------------
ConcatWithMaps: Concat: Vendor | 3498ms
Slowest Trees (cumulative) | Total (avg)
----------------------------------------------+---------------------
ConcatWithMaps: Concat: Vendor (1) | 3498ms

The problem comes when I go to http://localhost:4200. Nothing gets loaded and the Chrome console is showing the following:


Uncaught Error: Assertion Failed: Ember Views require jQuery between 1.7 and 2.1
Uncaught Error: Could not find module `ember` imported from `sample-app/app`

I tried to fix this by reinstalling ember-cli, bower and npm but nothing is working.


Here's additional info in case is necessary:


$ ember -v
version: 1.13.13
node: 5.4.0
npm: 2.14.10
os: darwin x64
$ npm -v
3.5.3
$ bower -v
1.7.2

Help is much appreciated. Thanks in advance!


Some Answers For Getting Uncaught Error Assertion Failed Ember Views Require Jquery Between 1

Please leave your answer here: